Вопрос задан 04.03.2021 в 03:26. Предмет Информатика. Спрашивает Алиев Рабадан.

1. составить программу вывода на экран всех трехзначных чисел, кратных 9. (паскаль, тремя

способами) 2. Составить программу вычисления суммы всех трехзначных чисел, кратных 17.(паскаль, тремя способами)
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Сорокина Даша.

1)

Program Pr1;
uses crt;
var mas:array[100..999] of integer;
i:integer;
Begin
clrscr;
for i:=100 to 999 do mas[i]:=i; {1 sposob}
for i:=100 to 999 do if mas[i] mod 9 =0 then writeln(mas[i]);
i:=100; {2 sposob}
while i<=999 do begin
if mas[i] mod 9=0 then writeln(mas[i]);
i:=i+1;
end;
i:=100; {3 sposob}
repeat
if mas[i] mod 9=0 then writeln(mas[i]);
i:=i+1
until i=999
end.

2)

Program Pr1;
uses crt;
var mas:array[100..999] of integer;
i,v:integer;
Begin
clrscr;
v:=0;
for i:=100 to 999 do mas[i]:=i; {1 sposob}
for i:=100 to 999 do if mas[i] mod 17 =0 then v:=v+mas[i];
writeln(v);
i:=100; {2 sposob}
v:=0;
while i<=999 do begin
if mas[i] mod 17=0 then v:=v+mas[i];;
i:=i+1;
end;
writeln(v);
i:=100; {3 sposob}
v:=0;
repeat
if mas[i] mod 17=0 then v:=v+mas[i];
i:=i+1
until i=999;
writeln(v);
end.

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно! Вот три способа написания программы на языке Паскаль для каждой из задач.

Программа вывода на экран всех трехзначных чисел, кратных 9:

  1. Способ 1:
pascal
program MultiplesOf9; var i: integer; begin for i := 100 to 999 do begin if i mod 9 = 0 then writeln(i); end; end.
  1. Способ 2:
pascal
program MultiplesOf9; var i: integer; begin i := 100; while i <= 999 do begin if i mod 9 = 0 then writeln(i); Inc(i); end; end.
  1. Способ 3:
pascal
program MultiplesOf9; var i: integer; begin i := 100; repeat if i mod 9 = 0 then writeln(i); Inc(i); until i > 999; end.

Программа вычисления суммы всех трехзначных чисел, кратных 17:

  1. Способ 1:
pascal
program SumOfMultiplesOf17; var i, sum: integer; begin sum := 0; for i := 100 to 999 do begin if i mod 17 = 0 then sum := sum + i; end; writeln('Сумма:', sum); end.
  1. Способ 2:
pascal
program SumOfMultiplesOf17; var i, sum: integer; begin sum := 0; i := 100; while i <= 999 do begin if i mod 17 = 0 then sum := sum + i; Inc(i); end; writeln('Сумма:', sum); end.
  1. Способ 3:
pascal
program SumOfMultiplesOf17; var i, sum: integer; begin sum := 0; i := 100; repeat if i mod 17 = 0 then sum := sum + i; Inc(i); until i > 999; writeln('Сумма:', sum); end.

Надеюсь, эти программы помогут вам!

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос