Вопрос задан 28.02.2021 в 20:17.
Предмет Информатика.
Спрашивает Бұрхан Ерсұлтан.
Нужна помощь. А. Напишите программу подсчета количества положительных, отрицательных чисел и
чисел, равных нулю. В. Перепишите следующую программу без ошибок и определите, какое значение будет иметь переменная P после выполнения программы, если с клавиатуры введено число 10? PROGRAM OL; Var a;b;h:integer BEGIN WriteLn(‘Введите число’ ); ReadLn(a); If a>=2 and a<=14 then begin b:=3; p=a*a+b*b end; else b:=5; p:=(a+b)*(a+b); WriteLn(‘p=’p); ENDОтветы на вопрос
Отвечает Цырковный Антон.
Задание А
Прикрепил в файле исходный код программы
Задание B
Прикрепил файл с исправленной программой, в которой присутствуют пометки, объясняющие ошибки. Ответ на второй вопрос:
При a = 10 переменная p примет значение 169.


Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, я могу помочь с этими задачами. Вот переписанная программа без ошибок:
cssPROGRAM OL;
Var
a, b, p: integer;
BEGIN
WriteLn('Введите число');
ReadLn(a);
If (a >= 2) and (a <= 14) then
begin
b := 3;
p := a * a + b * b;
end
else
begin
b := 5;
p := (a + b) * (a + b);
end;
WriteLn('p = ', p);
END.
Теперь программа будет работать правильно. Если с клавиатуры введено число 10, то переменная p будет иметь значение 169.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
