Вопрос задан 28.02.2021 в 20:05.
Предмет Информатика.
Спрашивает Камышникова Арина.
Pascal ABC. Даны 2 слова, отделенные друг от друга запятой. Написать программу, которая удаляет
запятую. ПОМОГИТЕ ПОЖАЛУЙСТА!!! ОЧЕНЬ СРОЧНО!!!Ответы на вопрос
Отвечает Смирнов Евгений.
Wort Pad если я не ошибаюсь
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно! Вот пример программы на языке Pascal ABC, которая удаляет запятую из двух слов, разделенных запятой:
pascalprogram RemoveComma; var input: string; word1, word2: string; begin // Ввод строки с двумя словами, разделенными запятой writeln('Введите два слова, разделенных запятой:'); readln(input); // Ищем позицию запятой var commaPos := pos(',', input); // Проверяем, что запятая найдена if commaPos = 0 then begin writeln('Запятая не найдена!'); exit; end; // Получаем первое слово до запятой word1 := copy(input, 1, commaPos - 1); // Получаем второе слово после запятой word2 := copy(input, commaPos + 1, length(input)); // Выводим результат writeln('Результат:'); writeln('Первое слово: ', word1); writeln('Второе слово: ', word2); readln; end.
Программа сначала запрашивает у пользователя ввод строки с двумя словами, разделенными запятой. Затем она ищет позицию запятой в строке с помощью функции pos(). Если запятая не найдена, программа выводит сообщение об ошибке и завершается. Если запятая найдена, программа разделяет строку на два слова с помощью функции copy() и выводит их на экран.
Надеюсь, это поможет вам! Если у вас возникнут еще вопросы, не стесняйтесь задавать.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
