
Вопрос задан 27.02.2021 в 06:36.
Предмет Информатика.
Спрашивает Быков Виктор.
Даю 40 баллов!!! Напишите программу в паскале. Даны два ненулевых числа. Найти сумму, разность,
произведение и частное их квадратов. входные данные: 2 1 выходные данные: 5 3 4 4

Ответы на вопрос

Отвечает Качанович Александра.
var a,b:real;
begin
readln (a,b);
write(sqr(a)+sqr(b) + ' ');
write(sqr(a)-sqr(b) + ' ');
write(sqr(a)*sqr(b) + ' ');
write(sqr(a)/sqr(b));
end.
begin
readln (a,b);
write(sqr(a)+sqr(b) + ' ');
write(sqr(a)-sqr(b) + ' ');
write(sqr(a)*sqr(b) + ' ');
write(sqr(a)/sqr(b));
end.



Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, вот программа на языке Паскаль, которая выполняет указанные вычисления:
pascalprogram Calculator; var num1, num2: real; sum, difference, product, quotient: real; begin write('Введите первое число: '); readln(num1); write('Введите второе число: '); readln(num2); sum := sqr(num1) + sqr(num2); difference := sqr(num1) - sqr(num2); product := sqr(num1) * sqr(num2); quotient := sqr(num1) / sqr(num2); writeln('Сумма квадратов: ', sum:0:2); writeln('Разность квадратов: ', difference:0:2); writeln('Произведение квадратов: ', product:0:2); writeln('Частное квадратов: ', quotient:0:2); end.
При запуске программы она будет запрашивать ввод двух чисел. После ввода она вычислит сумму, разность, произведение и частное их квадратов и выведет результаты на экран.
Пожалуйста, убедитесь, что у вас установлена среда разработки Pascal (например, Free Pascal) для запуска данной программы.


Топ вопросов за вчера в категории Информатика

Информатика 47

Информатика 33

Информатика 67

Информатика 18

Информатика 25

Информатика 563

Информатика 16
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili