
Вопрос задан 25.02.2021 в 16:26.
Предмет Информатика.
Спрашивает Унгуряну Настёна.
Составить программу поиска в целочисленном массиве из 15 элементов двух рядом стоящих элементов,
сумма которых больше 10, если таких элементов нет, вывести "NO". В паскале.

Ответы на вопрос

Отвечает Крупин Никита.
Const n=15;
var
a: array [1..n] of integer;
i:integer;
p:boolean;
begin
p:=true;
for i:= 1 to n do
begin
write('Введите A[',i,']: ');
readln(a[i]);
end;
i:=1;
while p and (i<n) do
begin
if a[i]+a[i+1]>10 then
begin
p:=false;
writeln;
writeln('(A[',i,']=',a[i],') + ((A[',i+1,']=',a[i+1],') > 10');
end;
inc(i);
end;
writeln;
if p then writeln('NO');
end.
var
a: array [1..n] of integer;
i:integer;
p:boolean;
begin
p:=true;
for i:= 1 to n do
begin
write('Введите A[',i,']: ');
readln(a[i]);
end;
i:=1;
while p and (i<n) do
begin
if a[i]+a[i+1]>10 then
begin
p:=false;
writeln;
writeln('(A[',i,']=',a[i],') + ((A[',i+1,']=',a[i+1],') > 10');
end;
inc(i);
end;
writeln;
if p then writeln('NO');
end.



Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Вот пример программы на языке Паскаль, которая выполняет поиск в целочисленном массиве из 15 элементов двух рядом стоящих элементов, сумма которых больше 10:
pascalprogram FindSum; const ARRAY_SIZE = 15; type IntArray = array[1..ARRAY_SIZE] of Integer; var arr: IntArray; i: Integer; found: Boolean; begin { Ввод элементов массива } writeln('Введите ', ARRAY_SIZE, ' целочисленных элементов массива:'); for i := 1 to ARRAY_SIZE do begin write('Элемент ', i, ': '); readln(arr[i]); end; { Поиск двух рядом стоящих элементов с суммой больше 10 } found := False; for i := 1 to ARRAY_SIZE - 1 do begin if (arr[i] + arr[i + 1]) > 10 then begin writeln('Найдены два рядом стоящих элемента с суммой больше 10:'); writeln('Элемент ', i, ': ', arr[i]); writeln('Элемент ', i + 1, ': ', arr[i + 1]); found := True; break; end; end; { Вывод результата } if not found then writeln('NO'); readln; end.
Программа запрашивает у пользователя ввод 15 целочисленных элементов массива. Затем она выполняет итерацию по массиву и проверяет каждую пару рядом стоящих элементов на сумму больше 10. Если такая пара найдена, программа выводит ее на экран. Если таких пар нет, программа выводит "NO".
Обратите внимание, что код может быть скомпилирован и выполнен в среде разработки, поддерживающей язык Паскаль.


Топ вопросов за вчера в категории Информатика

Информатика 47

Информатика 33

Информатика 67

Информатика 18

Информатика 25

Информатика 563

Информатика 16
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili