Вопрос задан 24.02.2021 в 23:32.
Предмет Информатика.
Спрашивает Юнаев Никита.
НА ПАСКАЛЕ ABC с простой версией(40 баллов) Задача: Среди заданных чисел найти количество
двухзначных чисел. Формат ввода: На первой строке задано количество чисел последовательности (неотрицательное, целое число не превосходящее 30000). На второй - элементы последовательности (целые числа в диапазоне от -30000 до 30000) через пробел. Формат вывода: Целое число. Пример входных данных 5 1 -20 -3 40 0 Пример выходных данных 2Ответы на вопрос
Отвечает Лебединская Арина.
Program n1;
var n,i,a,k: integer;
begin
readln(n);
k:=0;
for i:=1 to n do
begin
read(a);
if abs(a) in [10..99] then k:=k+1;
end;
write(k);
end.
var n,i,a,k: integer;
begin
readln(n);
k:=0;
for i:=1 to n do
begin
read(a);
if abs(a) in [10..99] then k:=k+1;
end;
write(k);
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Вот решение задачи на языке Pascal:
pascalprogram CountTwoDigitNumbers; var N, i, count: integer; num: array of integer; begin readln(N); // Читаем количество чисел // Инициализируем массив SetLength(num, N); // Читаем числа и заполняем массив for i := 0 to N - 1 do read(num[i]); count := 0; // Инициализируем счетчик двухзначных чисел // Проверяем каждое число for i := 0 to N - 1 do begin if (num[i] >= 10) and (num[i] <= 99) then count := count + 1; // Если число двухзначное, увеличиваем счетчик end; writeln(count); // Выводим результат end.
В этой программе мы сначала читаем количество чисел N, затем читаем числа в массив num. Затем мы инициализируем переменную count для хранения количества двухзначных чисел и начинаем проверку каждого числа в массиве. Если число находится в диапазоне от 10 до 99 (включительно), мы увеличиваем счетчик count. В конце выводим значение счетчика count.
Пример ввода:
5 1 -20 -3 40 0
Пример вывода:
2
В данном случае из пяти заданных чисел только 40 и -20 являются двухзначными числами, поэтому результатом будет 2.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
