Вопрос задан 21.02.2021 в 13:07.
Предмет Информатика.
Спрашивает Ибрагимов Рафаэль.
Пожалуйста помогите написать программу по информатики для решения задачи: В массиве рост юношей
задан отрицательным числом, рост девушек положительным, определите отдельно средний рост юношей и девушек и можно это сделать как нибудь примерно так? program xxx; var M,D,i,ran:integer; a:array [1..10] of integer; begin for i:=1 to 10 do ran:=100-random(200)+1; for i:=1 to 10 do if a[i]<0 then M:=M+a[i] else D:=D+a[i]; write (M,' '); write (D,' ') end..Ответы на вопрос
Отвечает Бабенко Настя.
//Не люблю "примерно так"
//PascalABC.NET 3.2 сборка 1318
Const
n=10;
Var
m,fm:real;
mc,fmc,i:integer;
val:array[1..n] of real;
begin
for i:=1 to n do
begin
readln(val[i]);
if val[i]>0 then
begin
inc(fmc);
fm+=val[i];
end
else
if val[i]<0 then
begin
inc(mc);
m+=abs(val[i]);
end
else
begin
writeln('Funny joke!(no)');
exit;
end;
end;
writeln('Male average=',m/mc);
writeln('Female average=',fm/fmc);
end.
//PascalABC.NET 3.2 сборка 1318
Const
n=10;
Var
m,fm:real;
mc,fmc,i:integer;
val:array[1..n] of real;
begin
for i:=1 to n do
begin
readln(val[i]);
if val[i]>0 then
begin
inc(fmc);
fm+=val[i];
end
else
if val[i]<0 then
begin
inc(mc);
m+=abs(val[i]);
end
else
begin
writeln('Funny joke!(no)');
exit;
end;
end;
writeln('Male average=',m/mc);
writeln('Female average=',fm/fmc);
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно! Вот ваша программа на языке Pascal:
pascalprogram xxx; var M, D, i, ran: integer; a: array [1..10] of integer; begin M := 0; D := 0; // Заполнение массива случайными значениями for i := 1 to 10 do begin ran := 100 - random(200) + 1; a[i] := ran; end; // Вычисление среднего роста юношей и девушек for i := 1 to 10 do begin if a[i] < 0 then M := M + a[i] else D := D + a[i]; end; // Вывод результатов writeln('Средний рост юношей: ', M / 10); writeln('Средний рост девушек: ', D / 10); end.
Обратите внимание, что вам нужно инициализировать переменные M и D нулевыми значениями до начала вычислений. Затем вы можете заполнить массив a случайными значениями, используя генератор случайных чисел. После этого можно пройтись по массиву и посчитать сумму роста юношей и девушек. Наконец, выведите средний рост для каждой группы.
Топ вопросов за вчера в категории Информатика
Информатика 22
Информатика 36
Информатика 60
Информатика 2166
Информатика 10
Информатика 571
Информатика 49
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
