Вопрос задан 18.02.2021 в 02:59. Предмет Информатика. Спрашивает Емельянова Света.

С++ Написать программу. Дано натуральное N и последовательность, состоящая из N целых чисел.

Определить наименьшее положительное среди данных чисел. (цикл-while)
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Сачук Настя.
#include <iostream>
int main(){  int N  = 0;
int c;
cin<<c; 
int minp=-1;
  while ( c>0) {
cin<<N; 
if(minp=-1&N>0)
minp=N;
else    if (N<minp&N>0)
minp = N;
c--;
  } cout>>minp;}
0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, вот пример программы на C++, которая решает вашу задачу с использованием цикла while:

cpp
#include <iostream> #include <climits> int main() { int N; std::cout << "Введите количество чисел N: "; std::cin >> N; int minPositive = INT_MAX; int i = 0; while (i < N) { int num; std::cout << "Введите число: "; std::cin >> num; if (num > 0 && num < minPositive) { minPositive = num; } i++; } if (minPositive != INT_MAX) { std::cout << "Наименьшее положительное число: " << minPositive << std::endl; } else { std::cout << "В последовательности нет положительных чисел." << std::endl; } return 0; }

Программа запрашивает у пользователя количество чисел N и затем последовательно запрашивает каждое число. В цикле while программа проверяет, является ли текущее число положительным и меньшим, чем текущее значение переменной minPositive. Если это так, то значение переменной minPositive обновляется. По окончании ввода чисел, программа выводит наименьшее положительное число, если такое есть, или сообщает, что в последовательности нет положительных чисел.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос