Вопрос задан 18.02.2021 в 02:15.
Предмет Информатика.
Спрашивает Кравец Влад.
Составить программу Паскаль, которая находит произведение n-нечётных чисел
Ответы на вопрос
Отвечает Стрижкин Назар.
var i,p: integer;
begin
p:=1;
for i:=1 to 13 do
if i mod 2 <> 0 then p:=p*i;
write (p)
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно! Вот пример программы на языке Паскаль, которая находит произведение n-нечётных чисел:
pascalprogram MultiplyOddNumbers; var n, i: integer; product: longint; begin writeln('Введите значение n:'); readln(n); product := 1; for i := 1 to n do begin if (i mod 2) <> 0 then product := product * i; end; writeln('Произведение ', n, ' нечётных чисел равно: ', product); readln; end.
При запуске программы она будет запрашивать у пользователя значение n. Затем, с помощью цикла for, программа проверяет каждое число от 1 до n и, если число нечётное, умножает его на текущее значение произведения product. В конце выполнения цикла программа выводит результат на экран.
Обратите внимание, что переменная product объявлена как longint, чтобы иметь возможность обрабатывать большие значения произведения.
Топ вопросов за вчера в категории Информатика
Информатика 75
Информатика 37
Информатика 11
Информатика 41
Информатика 22
Информатика 268
Информатика 36
Информатика 30
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
