Вопрос задан 16.02.2021 в 20:03.
Предмет Информатика.
Спрашивает Майборода Елизавета.
Составить программу нахождения произведения чисел: 1/2, 2/3 ... 9/10 Язык: Pascal
Ответы на вопрос
Отвечает Григорьева Даша.
Var
chisl, znam, multi: real;
begin
multi := 1;
chisl := 1;
znam := 2;
for var k := 1 to 9 do
begin
multi *= chisl / znam;
chisl += 1;
znam += 1;
end;
write(multi);
end.
chisl, znam, multi: real;
begin
multi := 1;
chisl := 1;
znam := 2;
for var k := 1 to 9 do
begin
multi *= chisl / znam;
chisl += 1;
znam += 1;
end;
write(multi);
end.
Отвечает Ларина Анна.
А если немножко подумать сначала?
Так что нужно просто вывести 0.1 ))))
begin
Writeln('0.1')
end.
Так что нужно просто вывести 0.1 ))))
begin
Writeln('0.1')
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, вот пример программы на языке Pascal для нахождения произведения чисел 1/2, 2/3, ..., 9/10:
pascalprogram НахождениеПроизведения; var i: integer; product: real; begin product := 1.0; // Инициализируем произведение единицей for i := 1 to 9 do begin product := product * (i / (i + 1)); // Умножаем текущее число на предыдущее произведение end; writeln('Произведение чисел: ', product:0:2); end.
В этой программе используется цикл for, который перебирает значения i от 1 до 9. В каждой итерации вычисляется новый элемент произведения путем умножения текущего числа на предыдущее произведение, деленное на i+1. Начальное значение произведения установлено равным 1.0.
Выводится результат, округленный до двух знаков после запятой. Вы можете изменить формат вывода, если требуется больше или меньше знаков после запятой.
Топ вопросов за вчера в категории Информатика
Информатика 47
Информатика 26
Информатика 32
Информатика 70
Информатика 43
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
