Вопрос задан 13.02.2021 в 16:48.
Предмет Информатика.
Спрашивает Болгова Анастасия.
Нужно написать программу в Паскале срочно: С клавиатуры вводится число n. Заполнить массив с
клавиатуры n значениями и вывести их произведение.Ответы на вопрос
Отвечает Шкуренкова Марина.
var
a: array of byte; //Мы ведь не хотим выйти за пределы даже Int64?
n, i: byte; //Больше и не пригодится, массива из 255 значений хватит уж
l: Int64 := 1; //Произведение - большая цЫферка
begin
readln(n);
System.Array.Resize(a, n);
for i := 0 to (n - 1) do
begin
write('a[', i, '] = ');
readln(a[i]);
l *= a[i];
end;
writeln(l);
end.
a: array of byte; //Мы ведь не хотим выйти за пределы даже Int64?
n, i: byte; //Больше и не пригодится, массива из 255 значений хватит уж
l: Int64 := 1; //Произведение - большая цЫферка
begin
readln(n);
System.Array.Resize(a, n);
for i := 0 to (n - 1) do
begin
write('a[', i, '] = ');
readln(a[i]);
l *= a[i];
end;
writeln(l);
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно! Вот программа на языке Pascal, которая выполняет указанную задачу:
pascalprogram MultiplyArray; const MAX_SIZE = 100; // Максимальный размер массива var arr: array[1..MAX_SIZE] of Integer; // Объявление массива n, i, product: Integer; begin Write('Введите размер массива: '); ReadLn(n); // Проверка на допустимый размер массива if (n < 1) or (n > MAX_SIZE) then begin WriteLn('Ошибка: недопустимый размер массива.'); Exit; // Выход из программы end; // Ввод элементов массива с клавиатуры WriteLn('Введите элементы массива:'); for i := 1 to n do begin Write('arr[', i, '] = '); ReadLn(arr[i]); end; // Вычисление произведения элементов массива product := 1; for i := 1 to n do begin product := product * arr[i]; end; // Вывод произведения WriteLn('Произведение элементов массива: ', product); ReadLn; // Чтобы консольное окно не закрылось сразу end.
Программа сначала запрашивает у пользователя размер массива n, затем просит ввести n элементов массива. После этого она вычисляет произведение всех элементов и выводит его на экран.
Убедитесь, что компилятор Pascal установлен на вашем компьютере, чтобы скомпилировать и запустить эту программу.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
