Вопрос задан 12.02.2021 в 08:30. Предмет Информатика. Спрашивает Котик Аня.

C++ 2. Задан числовой массив А[1:m, 1:n]. Составить программу поиска элемента массива, который

является наибольшим из отрицательных чисел расположенных в строках.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Распопов Егор.
///////////////////////////////////

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Вот пример программы на языке C++, которая выполняет поиск наибольшего отрицательного числа в каждой строке числового массива А[1:m, 1:n]:

cpp
#include <iostream> const int MAX_SIZE = 100; int findMaxNegative(int arr[][MAX_SIZE], int rows, int cols) { int maxNegative = INT_MIN; for (int i = 0; i < rows; i++) { for (int j = 0; j < cols; j++) { if (arr[i][j] < 0 && arr[i][j] > maxNegative) { maxNegative = arr[i][j]; } } } return maxNegative; } int main() { int m, n; int arr[MAX_SIZE][MAX_SIZE]; std::cout << "Введите количество строк (m): "; std::cin >> m; std::cout << "Введите количество столбцов (n): "; std::cin >> n; std::cout << "Введите элементы массива:\n"; for (int i = 0; i < m; i++) { for (int j = 0; j < n; j++) { std::cin >> arr[i][j]; } } int maxNegative = findMaxNegative(arr, m, n); if (maxNegative != INT_MIN) { std::cout << "Наибольшее отрицательное число: " << maxNegative << std::endl; } else { std::cout << "Отрицательных чисел не найдено." << std::endl; } return 0; }

В этой программе мы сначала определяем функцию findMaxNegative, которая принимает массив arr, количество строк rows и количество столбцов cols. Внутри этой функции мы инициализируем переменную maxNegative со значением INT_MIN (наименьшее возможное значение типа int), которая будет хранить текущий максимальный отрицательный элемент.

Затем мы используем два вложенных цикла for для прохода по каждому элементу массива. Если текущий элемент отрицательный и больше текущего maxNegative, мы обновляем значение maxNegative.

В функции main мы сначала запрашиваем у пользователя количество строк (m) и столбцов (n). Затем мы заполняем массив arr значениями, введенными пользователем. После этого мы вызываем функцию findMaxNegative и выводим найденный результат на экран.

Надеюсь, это поможет! Если у вас есть еще вопросы, не стесняйтесь задавать.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос