Вопрос задан 30.11.2020 в 10:01.
Предмет Информатика.
Спрашивает Бармакова Яна.
Напишите программу, которая находит в матрице столбцы, в которых есть элемент, равный
максимальному. Входные данные В первой строке записаны через пробел размеры матрицы: количество строк N и количество столбцов M ( 1 ≤ N , M ≤ 100 ). В следующих N строках записаны строки матрицы, в каждой – по M натуральных чисел, разделённых пробелами. Выходные данные Программа должна вывести все столбцы, в которых есть элемент, равный максимальному элементу в матрице. Каждый столбец выводится в одну строку, элементы разделяются пробелами.Ответы на вопрос
Отвечает Михайлова Даша.
Pascal
program matr;uses CRT;var fl:char;a:array [1..100,1..100] of integer;i,j,m,n,mmax:byte;max:integer;label met;beginmet:clrscr;max:=0;writeln ('Введите размерность матрицы NxM');readln (n);readln (m);randomize;for i:=1 to n do beginfor j:=1 to m do begina[i,j]:=-50+random(101);write (a[i,j]:4);end;{создание и вывод матрицы}writeln;end;writeln;for i:=1 to n do{нахождение максимального элемента}zfor j:=1 to m doif (a[i,j]>max) then beginmax:=a[i,j];mmax:=j;end;for i:=1 to n dowrite (a[i,mmax]:4);writeln;{Вывод столбца}for i:=1 to n do {нахождение одинаковых элементов}for j:=1 to n doif (a[i,j]=max)and(j<>mmax) then begin mmax:=j;write (a[i,mmax]:4);end;writeln ('Для продолжения нажмите любую клавишу,для выхода - "Х"');readln(fl);if (fl <> 'x') then goto met;end.
program matr;uses CRT;var fl:char;a:array [1..100,1..100] of integer;i,j,m,n,mmax:byte;max:integer;label met;beginmet:clrscr;max:=0;writeln ('Введите размерность матрицы NxM');readln (n);readln (m);randomize;for i:=1 to n do beginfor j:=1 to m do begina[i,j]:=-50+random(101);write (a[i,j]:4);end;{создание и вывод матрицы}writeln;end;writeln;for i:=1 to n do{нахождение максимального элемента}zfor j:=1 to m doif (a[i,j]>max) then beginmax:=a[i,j];mmax:=j;end;for i:=1 to n dowrite (a[i,mmax]:4);writeln;{Вывод столбца}for i:=1 to n do {нахождение одинаковых элементов}for j:=1 to n doif (a[i,j]=max)and(j<>mmax) then begin mmax:=j;write (a[i,mmax]:4);end;writeln ('Для продолжения нажмите любую клавишу,для выхода - "Х"');readln(fl);if (fl <> 'x') then goto met;end.
Топ вопросов за вчера в категории Информатика
Информатика 75
Информатика 37
Информатика 11
Информатика 41
Информатика 22
Информатика 268
Информатика 36
Информатика 30
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
