Вопрос задан 20.11.2020 в 16:20.
Предмет Информатика.
Спрашивает Нефедова Екатерина.
Дан массив, состоящий из целых чисел. Напишите программу, которая в данном массиве определит
количество элементов, у которых два соседних и, при этом, оба соседних элемента меньше данного. Входные данные Сначала задано число N — количество элементов в массиве (1N100). Далее через пробел записаны N чисел — элементы массива. Массив состоит из целых чисел. Выходные данные Необходимо вывести количество элементов массива, у которых два соседа и которые при этом строго больше обоих своих соседей. Примеры Входные данные 5 1 2 3 4 5 Выходные данные 0 Входные данные 5 1 5 1 5 1 Выходные данные 2Ответы на вопрос
Отвечает Курганова Диана.
Var i,num,s:integer;
arr:array of integer;
begin
readln(num);
setlength(arr,num);
for i:=0 to num-1 do begin
read(arr[i]);
if i>1 then begin
if (arr[i-2]<arr[i-1]) and (arr[i]<arr[i-1]) then s+=1;
end;
end;
writeln('',s);
end.
arr:array of integer;
begin
readln(num);
setlength(arr,num);
for i:=0 to num-1 do begin
read(arr[i]);
if i>1 then begin
if (arr[i-2]<arr[i-1]) and (arr[i]<arr[i-1]) then s+=1;
end;
end;
writeln('',s);
end.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
