Вопрос задан 14.11.2020 в 18:07. Предмет Информатика. Спрашивает Кальник Роман.

Напишите программу в паскале ABC, и нарисуйте к ней блок-схему. Вводится массив из 15

элементов,нужно определить сколько эл. массива будут между его макс и миним. элементом.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Зиброва Владелина.
Var
i,max,min,res,maxi,mini:integer;
a: array [1..15] of integer;
begin
writeln('Введите числа');
for i:=1 to 15 do
read(a[i]);
max:=a[1];
min:=a[1];
for i:=1 to 15 do
begin
if max<a[i] then begin
max:=a[i];
maxi:=i;
end;
if min>a[i] then begin
min:=a[i];
mini:=i;
end;
end;
if maxi>mini then
res:=maxi-mini
else
res:=mini-maxi;
res:=res-2;
writeln('между максимум и минимум = ', res, ' элементов');
end.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос