Вопрос задан 14.11.2020 в 09:20.
Предмет Информатика.
Спрашивает Намятова Соня.
9. Написать программу вычисления функции у: у=sqrt(х+5).если x>0. у= sqrt(5+х), если x<=0 В
случае отрицательного подкоренного выражения выводится надпись "Останов" и программа заканчивается.Ответы на вопрос
Отвечает Черман Алина.
Программа вкратце.
Если посещал уроки то сможешь ее написать чтоб работала.
В условии задачи ошибка, наверное вместо - написал плюс.
y = sqrt(х+5). если x>0.
пусть здесь будет так: у= sqrt(5-х). если x<0
Program radical;
var x,y:integer;
Begin
readln(x);
if ((x+5) >= 0) and ((5-х) >=0)) then begin
{ проверка чтобы не-было меньше нуля }
if (x>0) then
y = sqrt(x+5);
else if (x<0) then
y = sqrt(5-x);
writeln('результат=', y);
end
else
writeln("нельзя извлечь корень из отрицательного числа");
readln();
End.
Если посещал уроки то сможешь ее написать чтоб работала.
В условии задачи ошибка, наверное вместо - написал плюс.
y = sqrt(х+5). если x>0.
пусть здесь будет так: у= sqrt(5-х). если x<0
Program radical;
var x,y:integer;
Begin
readln(x);
if ((x+5) >= 0) and ((5-х) >=0)) then begin
{ проверка чтобы не-было меньше нуля }
if (x>0) then
y = sqrt(x+5);
else if (x<0) then
y = sqrt(5-x);
writeln('результат=', y);
end
else
writeln("нельзя извлечь корень из отрицательного числа");
readln();
End.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
