Вопрос задан 14.06.2018 в 08:00.
Предмет Информатика.
Спрашивает Шакуров Егор.
В питоне Напишите программу, которая определяет, является ли заданная строка (возможно, содержащая
пробелы) палиндромом, то есть верно ли, что она после удаления пробелов читается одинаково слева направо и справа налево. Входные данные Входная строка – последовательность символов, возможно, содержащая пробелы. Выходные данные Программа должна вывести слово 'YES', если введённая строка – палиндром, и слово 'NO', если она не является палиндромом. Примеры входные данные ka za k выходные данные YES входные данные kaza n выходные данные NO Сдать:Ответы на вопрос
Отвечает Плаксина Виктория.
НА ПРИМЕРЕ В ЭТОЙ ЗАДАЧИ
program z1;
uses crt;
const
st1='ма';
st2='ма';
var
str:string;
i,k:integer;
begin
write('введите строку: ');readln(str);
for i:=1 to length(str) do
if (st1=copy(str,i,2)) or (st2=copy(str,i,2)) then
k:=k+1;
writeln(k);
end.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
