Вопрос задан 31.10.2020 в 03:58.
Предмет Информатика.
Спрашивает Эль-Гохари Тарек.
Составьте программу , которая с четырьмя произвольными числами а,x,z и w , введенными с клавиатуры,
производит вычисления по следующим формулам: Во вложении.
Ответы на вопрос
Отвечает Марвина Мая.
PascalABC.NET 3.3.5, сборка 1660 от 20.04.2018
Внимание! Если программа не работает, обновите версию!
begin
var a,x,z,w:real; Read(a,x,z,w);
var b:=((z*z-a*a)*7.5-3*(z**3+w)**2+3*x)/(25*x*a*w+33.7*z*z)*z;
var c:=b+a/(5-x/3)**3+120.5*b*x;
var e:=(a*b*c-175*a*(b-3))/(a*b*b*c+17*a*z);
var f:=2*b+3*e-c*b;
Writeln(b:0:5,' ',c:0:3,' ',e:0:4,' ',f:0:3)
end.
Внимание! Если программа не работает, обновите версию!
begin
var a,x,z,w:real; Read(a,x,z,w);
var b:=((z*z-a*a)*7.5-3*(z**3+w)**2+3*x)/(25*x*a*w+33.7*z*z)*z;
var c:=b+a/(5-x/3)**3+120.5*b*x;
var e:=(a*b*c-175*a*(b-3))/(a*b*b*c+17*a*z);
var f:=2*b+3*e-c*b;
Writeln(b:0:5,' ',c:0:3,' ',e:0:4,' ',f:0:3)
end.
Отвечает Топчег Кирюша.
Паскаль
var a,b,c,d,e,f,w,x,z:real;
begin
read(a,x,z,w);
b:=((sqr(z)-sqr(a))*7.5*z-3*z*sqr(power(z,3)+w)+3*x*z)/(25*x*a*w+33.7*sqr(z));
c:=b+(a/power((5-x/3),3))+120.5*b*x;
e:=(a*b*c-175*a*(b-3))/(a*sqr(b)*c+17*a*z);
f:=2*b+3*e-c*b;
write(b:0:5,' ',c:0:3,' ',e:0:4,' ',f:0:3);
end.
var a,b,c,d,e,f,w,x,z:real;
begin
read(a,x,z,w);
b:=((sqr(z)-sqr(a))*7.5*z-3*z*sqr(power(z,3)+w)+3*x*z)/(25*x*a*w+33.7*sqr(z));
c:=b+(a/power((5-x/3),3))+120.5*b*x;
e:=(a*b*c-175*a*(b-3))/(a*sqr(b)*c+17*a*z);
f:=2*b+3*e-c*b;
write(b:0:5,' ',c:0:3,' ',e:0:4,' ',f:0:3);
end.

Топ вопросов за вчера в категории Информатика
Информатика 35
Информатика 54
Информатика 12
Информатика 263
Информатика 25
Информатика 33
Информатика 16
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
