 
Вопрос задан 13.06.2018 в 02:10.
Предмет Информатика.
Спрашивает Гольц Владимир.
Написать программу в Паскаль абс по теме функции. задача: найти сумму цифр трех чисел.
 0
        0
         0
        0
    Ответы на вопрос
 
        Отвечает Филиппов Михаил.
                
     // PascalABC.NET 3.1, сборка 1219 от 16.04.2016
function SoD(n:int64):integer;
begin
  Result:=0;
  while n>0 do begin
    Result+=n mod 10;
    n:=n div 10
    end
end;
    
begin
  var a:=ReadArrInteger('Введите три натуральных числа:',3);
  Write('Суммы цифр чисел: '); a.Select(x->SoD(x)).Println;
  Writeln('Общая сумма цифр всех чисел: ',a.Select(x->SoD(x)).Sum)
end.
Тестовое решение:
Введите три натуральных числа: 56325 23131 784545223
Суммы цифр чисел: 21 10 40
Общая сумма цифр всех чисел: 71
 0
                    0
                     0
                    0
                Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
	- 
			Математика 
- 
			Литература 
- 
			Алгебра 
- 
			Русский язык 
- 
			Геометрия 
- 
			Английский язык 
- 
			Химия 
- 
			Физика 
- 
			Биология 
- 
			Другие предметы 
- 
			История 
- 
			Обществознание 
- 
			Окружающий мир 
- 
			География 
- 
			Українська мова 
- 
			Информатика 
- 
			Українська література 
- 
			Қазақ тiлi 
- 
			Экономика 
- 
			Музыка 
- 
			Право 
- 
			Беларуская мова 
- 
			Французский язык 
- 
			Немецкий язык 
- 
			МХК 
- 
			ОБЖ 
- 
			Психология 
- 
			Физкультура и спорт 
- 
			Астрономия 
- 
			Кыргыз тили 
- 
			Оʻzbek tili 
 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			